AMF not connecting with gNB

Hi all,

I am trying to connect free5GC with a Nokia Airscale, but I am getting some strange problems regarding the AMF connection. I am attaching the configs and logs. Can someone help me? Below is the atchitecture overview:

free5gc(sa)

free5gc.7z (76.2 KB)

Hi,
The error seems like encounter some TA things:

time="2020-11-25T12:00:19-03:00" level=error msg="Registration Reject[Tracking area not allowed]" category=Gmm component=AMF

Does the TAC in the RAN same as TAC on AMF’s config?

Yes, they are both set for 8101. Attached the output of Nokia gNB.

Is your NRF running?

Thank you for your answer!
You are right, the NRF was not running. Now its running, but still no progress from the gNB side, I am sending the SCTP but an abort message is sent from the core side. Attached the new logs

free5gc.7z (79.7 KB)

Is it possible to provide some pcap file?

There is also some address error on the new output file, may you check on it?

Sure, I have changed the AMF config and now the SCTP seems to be much better. However, now I am getting the following error:

2020-12-11T07:25:31-03:00 [ERRO][AMF][NGAP] Build NGSetupResponse failed : OctetString Length is over upperbound (/home/free5gc/free5gc/src/amf/ngap/message/send.go:87 free5gc/src/amf/ngap/message.SendNGSetupResponse)

Attached the logs, unfortunately the pcap is too big to upload a bit more than 4.5MB zipped, I am sending two links (one more alternativa) with the pcap:

https://app.boxcn.net/s/vjkvjb5bfdleiaq5crbywkeb4ngkhwgc

The google drive’s link is not accessible.

Quick update, I was able to get through by setting the sd as an hexadecimal (D143A5). However, something strange happened after it, the first time the AMF blinked on the gNB side and I got a lot of messages after the SCTP accept, I have saved the output as “output.txt”, unfortunately I was not able to pick up this specific pcap. Then, I tried to run it again and the output was different, I got stuck at the SCTP accept, this one I was able to save the pcap and the output as “output2.txt”, all files are attached. Can you guys help me? I am feeling we are getting really near an integration between them.

free5gc.zip (217.9 KB)

On the pcap file, after RAN send SCTP COOKIE_ACK, it keep sending HEARTBEAT but not sending NGSetup Request.

The heartbeat seems fine, but I’m not sure why your RAN didn’t start to do the ng setup procedure. Maybe you should re-start your RAN?

On your first output, it crash on

I suppose that supportedTAList.List is null, may you help to check if these lines has been successfully jump into?

Maybe when the ConfigurationUpdate didn’t update SupportedTAList, free5GC didn’t welly handle the message.