Fetch Registered UE Request fail - No AMF Found


It looks as a very frequently asked question, and I’m sure that I’m not the only one to face it, so I hope to find here a solution:

I downloaded free5gc-compose and followed the instruction exactly (detailed below in a separate reply, because the forum limits the number of links to 2 per a message), and everything was compiled and built without errors. Then I ran it, accessed it from the browser, and was asked for username/password. After login, I reached the dashboard, but then the following message was displayed:
Real Time Status
Fetch Registered UE Request fail

I looked at the inspector, and saw that this is the result of
Except for that, everything worked.

So I tried to replace localhost by the real address, and accessed it directly
(by - is the IP of the host of the containers).
That request returned the following JSON:
{“cause”:“No AMF Found”}

I also tried to run a browser on the host of the containers (so localhost is correct) and instead of “Fetch Registered UE Request fail” (because localhost caused it to connect to the client machine), I received the following:
Real Time Status
No AMF Found

I want to emphasize that except for that, everything worked perfectly!
So I’m sure that I missed something small and silly.

Thank you very much,

The question seems similar to issue#57 below, currently we are working on it. Any new development it will be updated at GitHub.

I know that the message is similar to a past issue, but the cause looks different.
I promised to detail the commands I used, but the forum haven’t let me do it before 11 hours passing. In addition, I use a screen shot because the forum doesn’t let me to use more than 2 links in one post, and I already spent my 2 links in the original message.
As you can see, I followed the instructions exactly, with no errors at all (till I reached the above page with my browser).
(Host is Ubuntu 14.04, kernel is 5.0.0-23)