UE unable to ping

I am using free5gc-compose. I can ping two UEs and it works fine (downlink). However, when I try to ping from a UE to for example, or google.com it does not work and I can see on wireshark that the packets are not leaving the UPF. I assume this is a routing problem that does not have anything to do with my configuration because otherwise, the downlink would not work. Can anyone help me with this?

You can try to ping or google.com from UPF Container.

I did and it worked! But the ping from the UERAN VM through the tunnel is still not working

Try the command:
‘ping -I uesimtun0’ in UERAN Container, It can’t working?

Could you provide the logs or screenshots so that we could try to find out the problem?

Can you please let me know what exactly it is that you want to check?


I’m not sure where the problem is, so maybe the logs for free5GC when UE registered and created the PDU session or the UERANSIM output.
PCAP file would be great.

You could try this free5gc-compose with UERANSIM, UE cannot connect to the internet · Issue #26 · free5gc/free5gc-compose · GitHub first.

Hello, I apologize for the late reponse I will be providing a detailed explanation of my issue alongside the pcap tomorrow. Thanks!