UPF - requests/responds?

Hello dear free5gc team,

my fellow student and I are trying to resend pfcp packages via scapy from the testRegistration test (which we captured with wireshark).
But we are struggeling to get a reply from the UPF.
We started the UPF independly as described on github and send the packages to,
but with no effect on the UPF. (Wireshark can capture our request but does not receive a reply).
Another thing we tried is to start the whole free5gc Network and send the packages to .
We also tried to change the checksums and mac addresses but with no success.

Maybe you have an idea why this doesnt work like that ?
Is it generally possible to use pfcp packets to test the N4 Interface or do we need to handle more in advance ?

Thank you very much in advance


Does UPF get any reaction and log or it just didn’t get any packet from kernel?

Hey, we are now able to send to and receive packets from the UPF.
The problem was that we did not set the right mac adress.
Solution for this was to send an ARP request to get the mac adress.(sudo arp -n did not work)
Thank you very much.