Why does the UPF module function correctly on a VM, but not on my local machine?

When I run the UPF module on a VM, it functions properly, and I can establish an internet connection through it. However, when I run the UPF on my local machine, all messages pass successfully, the tunnel is created without any issues, but when I attempt to ping through UERANSIM, there is no response.

Are there any limitations on running free5gc on a local machine?

Hello, this is Leon
There are no limitations on executing free5gc on your local computer. You said that you cannot ping through UERANSIM. The most common reason for this problem is that the IP address setting in your configuration file is incorrect. Can your local machine and virtual machine ping each other? If so, you can check your config file and check your IP address settings.
You can read our installation guide and check your steps correctly.


Good luck,

Thank you for your response,
I have checked all IP configurations in all the YAML files and they are all correct,I guess there are some problems in routing table configurations,I will recheck the IP Tables in my local machine and get back to you

since there haven’t any replies from you, the admin decides to close this topic.
If you have any further questions about this topic, please message the admin or create another topic.